Aldi-Suiss-Tours - Booking, Justaway Deutschland - Booking, and 4 other services are down
Resolved
Sep 10 at 02:53pm CEST
Justaway Deutschland - Booking and Justaway TCI - Booking recovered.
Affected services
Updated
Sep 10 at 02:53pm CEST
Justaway EAG - Booking recovered.
Affected services
Updated
Sep 10 at 02:53pm CEST
Aldi-Suiss-Tours - Booking, Justaway FOEG - Booking, and Hofer Reisen - Booking recovered.
Affected services
Updated
Sep 10 at 02:49pm CEST
Justaway Deutschland - Booking, Justaway EAG - Booking, and Justaway TCI - Booking went down.
Affected services
Created
Sep 10 at 02:49pm CEST
Aldi-Suiss-Tours - Booking, Justaway FOEG - Booking, and Hofer Reisen - Booking went down.
Affected services